Knot-of-nots: Avoiding negative names for boolean methods
The usual convention to name methods that return boolean is to prefix verbs such as ‘is’ or ‘has’ to the predicate as a question, or use the predicate as an assertion. For example, to check if a user is active, you would say user.isActive() or to check if the user exists, you would say user.exists(). But when the intention is to check if the user is not active, I’ve come across code that is written as user....